How to fix bricked WD My Book World Edition White Light or install brand new disk?

Wersja w języku polskim jest tutaj.

Problem

I bought brand new WD Caviar Green hard disks and put them into My Book World Edition II White Light case but… surprisingly it doesn’t work or even start! Only top LED is blinking/flashing and MBWE doesn’t appear in my network environment! Similar situation is with WD My Book World Edition I White Light or with my previous HDD that has stopped working.

How to recover or rebuild firmware of bricked WD My Book World Edition White Light or install/replace brand new hard disk(s)?

Also following questions will find here their answers:

  • Which disk to buy for WD My Book World Edition White Light?
  • How to increase/upgrade WD My Book World Edition White Light capacity to 3TB/4TB (MBWE I) or 6TB/8TB (MBWE II)?
  • How to downgrade WD My Book World Edition White Light firmware version?
  • How to clean personal data (completely erase to the factory defaults) WD My Book World Edition White Light in purpose of sale?

MBWE Blue Rings Note

This tutorial does not not work with MBWE Blue Rings, because it has different firmware which has to be reverse-engineered to create similar solution. It can only serve as a clue how to do it.

Healthy NAS Upgrade Note

If you just want to upgrade your healthy MBWE II to 2x3TB HDDs or more, try this simplest community.wd.com solution. I haven’t tested it but it sounds like you can also preserve your data.

What’s going on?

If suddenly your MBWE has stopped working, firstly decode your MBWE situation by LEDs state/action and refer to the My Book World Edition User Manual on page 10 (LED Indicators). Maybe nothing serious has happened there but only something unusual.

Anyway, MBWE boots from NAS OS written on disk, so you can’t start MBWE:

  • with brand new clean disk(s) or
  • when your current disk(s) has broken boot partition or master boot record (MBR).

There is no user procedure provided by Western Digital to repair MBWE or start brand new disks. You can only return complete MBWE (with disk(s)) to Western Digital to get a new one, if you have void warranty (for warranty conditions see: support.wdc.com).

I couldn’t agree with this, so I decided to make it on my own and here it is…

What’s this?

This is linux bash script solution to restore MBWE White Light (install firmware once again) with a FACTORY STATE and CLEAN DISK:

  • Works with both MBWE White Light (I and II) with any size of disk (even 4TB or 2x4TB)! It fully supports only WD Caviar disks! It means that you can use other vendor disk like Samsung or Maxtor (this solution is prepared for this) but forget then about: updating firmware, replacing disk, reformatting or changing RAID mode. Full support of other vendors requires wide firmware hack against this operations except firmware update which cannot be hacked (new firmware can simply overwrite these hacks). If you are interested in hacked firmware, ask in comment – I can do this but for a fee. Anyway, I strongly recommend to use WD disks only – it’s free and safe.
    Be aware also that not all WD Caviar Green drives seem to be MBWE compatible! (see WARNING below for details).
  • Designed to auto download & install always the latest MBWE firmware directly from wdc.com (manually available here and fw revision info is here). But you can also install any firmware since & including ver. 01.02.06, that I’ve tested on 2011-04-20. If you encounter any problem with the latest version, just pick ver. 01.02.06 (mirror) and use it in step 3 of procedure below, then upgrade to the latest firmware using native MBWE management interface any time you want.
  • Full install takes less than 1 minute! excluding firmware download.
  • In MBWE II only 1 disk needs to be prepared! – the second one (clean) will be adopted by MBWE itself.
  • Config with only 4 lines to adjust: disk label, serial number, model type, MAC address.
  • 1 script to fire! and little wizard will guide you.

1st WARNING !!!

This solution WILL ERASE ALL YOUR DISK DATA, if you connect your old disk!

If you want to rescue data on bricked MBWE, contact Western Digital on wdc.custhelp.com or go to data recovery guide to make your data copy before this operation (4th partition is DataVolume partition) and move them back to your „new” MBWE. This should be possible if you got MBWE I or MBWE II with RAID 1 (Mirrored) or JBOD array mode. In other case, you shouldn’t do anything but call Western Digital if you care your data and you don’t know what to do.

Don’t buy new WD Caviar Green disk without being sure this model works with your MBWE!

As Western Digital online customer support says, Advanced Format Drives are not compatible with MBWE but they don’t say which one particularly is advanced/incompatible (more about Advanced Format Technology)Particular WD Caviar Green disk models with MBWE compatibility statuses are (for specs go to wdc.com or Specs Sheet):

  • EADS, EAVS, EACS (SATA II 3Gb/s) are definitly compatible as WD says.
  • EARS (SATA II 3Gb/s) are compatible as tested on my own and by the community.
  • EARX (SATA III 6Gb/s) compatibility varies as community report success (3 cases) as well as failures (2 cases). WD support says it may or may not work due to relatively older MBWE SATA II interface. If you’ve encountered any issues, try different jumper settings as a last resort (see pic).
  • EZRX (SATA III 6Gb/s) compatibility varies – some users succeeded (here is the proof of 2x3TB WD30EZRX and 2x4TB WD40EZRX) and some report failure. There is a suspicion that revision R/N B3D (labeled on the bottom, right under WD logo) is not compatible with EZRX (report) but results also varies.
  • EADX, EZRSDTL (SATA III 6Gb/s) compatibility unknown yet.
  • AACS (SATA II 3Gb/s) are compatible as reported by community.

Sometimes connecting HDD directly to the computer SATA controller instead of using external SATA adapters can help (see Troubleshooting below).

Even though some of the users report success with WD Caviar Black or Red, I don’t recommend them due to higher work temperature than WD Caviar Green. Bear in mind, that MBWE is passively cooled and excessive temp. can shorten HDD life or even damage MBWE electronics.

NOTICE: If you buy new disks to your MBWE II, it would be better (if possible) to take both disks of the same type and the same part (production series) due to RAID performance and conformance. Therefore, you should buy both disks from the same retailer at once (at the same time).

Quick How-To

2nd WARNING !!!

You should never ever run this script on a production environment!
I strongly recommend to unplug any attached hard disks from the computer you are going to use to run this script, except the HDD you want to install firmware to. This way you’re avoiding any mistakes that can unrecoverably destroy your data.

  1. Prerequisites
    If your HDD contains any data or structure (isn’t brand new), you must wipe it out beforehand (unallocated space = no partitions, unformatted – just raw). This can be done using Computer Manager > Disk Management under Windows or using Disk Utility under Ubuntu.
    You should also check your HDD against bad sectors because MBWE firmware is based on some absolute blocks and thus they cannot be bad or mapped as bad.
  2. 1 Boot the latest Ubuntu
    from optical drive or flash/pen/USB drive (USB is far faster than optical), or direct HDD. How-To on ubuntu.com in Download Ubuntu section. Choose Try Ubuntu (it will boot directly without any changes on your system drive). NOTICE:
    If you have problems with other linux distributions/versions simply use Ubuntu 12.04.3 LTS, because I tested it (screenshots below were taken long time ago on Ubuntu 10.10)
    .
    DO NOT USE ANY VIRTUAL MACHINE – it can cause many additional issues and mostly does not work in this low level operation.Ubuntu Try
  3. Wire your computer
    to the Internet
    (wireless connection is often not possible due to lack of many Ubuntu CD WiFi drivers and it’s not our goal to play with it here).
  4. 3 Extract mbwe.tar.gz
    (right click and choose Extract Here) on the Desktop (and all files should be placed in folder mbwe – if not, correct this). If you predownloaded firmware image manually (on wdc.com or mirror), place it in mbwe folder and rename it to fw.img
  5. 4 Connect your hard disk
    directly to the computer SATA controller (if possible) or alternatively using SATA-to-USB adapter (or any other hotplug way, e.g. FireWire, eSATA). Find your disk label using Disk Utility (go to the top bar menu System Administration Disk Utility) as shown on the picture below (here it is sdc but yours can be different).
    Ubuntu Disk Utility
  6. 5 Edit mbwe-config.sh file
    in folder mbwe (right click on the file, choose Open in another application and select gedit editor) and type your HDD and MBWE parameters (DISK_LABEL, MBWE_TYPE, MBWE_SERIAL and MAC_ADDRS) according to comments. Save file (CTRL+S) and close gedit.
    NOTICE: If you really want to do this step on your own (some people are stubborn) then  DO NOT EVER USE word processor like Word nor Wordpad to edit *.sh files – it must be a plain text (txt file) Notepad like editor (here Gedit). Otherwise, you might break these files leaving hidden formatting characters and leading to unexpected results/errors.
    Ubuntu MBWE Config
  7. 6 Open Terminal
    (CTRL+ALT+T) and type:
    cd Desktop/mbwe
    sudo bash ./mbwe-install.shUbuntu Terminal
  8. 7 Listen carefully
    what is Terminal asking you and obey its commands.
    Ubuntu Terminal mbwe-install.sh
  9. 8 After Safe Removed disk
    using Disk Utility (click Safe Removal button), unplug MBWE from the power supply and place HDD in MBWE bay (any bay in MBWE II).
    Ubuntu Disk Utility Safe Removal
  10. 9 Plug MBWE to the power supply back
    and wait al least 30 seconds (up to several minutes) until MBWE initializes and shuts down itself (all LEDs go off). Then hold Power button (approx. for 3 seconds) until bottom LED goes on and wait at least 3 minutes for MBWE to boot up. Then go through the first start procedure in MBWE web GUI (provide MBWE IP address in your web browser and log in as admin/admin).
  11. 10 For MBWE I that’s all.

For MBWE II go further:

  1. 11 Shutdown MBWE
    by holding Power button for up to 3 seconds (no longer than 4 seconds, which forces device to power off immediately) and wait untill all LEDs are off, then unplug from the power supply and put your second clean disk in an empty bay. If your second disk contains any data or structure (isn’t brand new), you must wipe it out beforehand (unallocated space = no partitions, unformatted) – see Prerequisites.
  2. 12 Power up MBWE again as described in step 9
    and voilà.

That’s all folks

If this saved your life, you can express your happiness by your little donation (click Donate button).
Thanks in advance!

Regardless you had issues or not, please leave your feedback:

  • Your MBWE version?MBWE I or MBWE II.
  • Your MBWE revision?: R\N B3D or other (labeled on the bottom, right under WD logo).
  • Your hard disk description?WD Caviar Green WD20EARS or other.
  • Your linux distro/version?Ubuntu 12.x Live CD or other.
  • Your firmware?: installed automatically by script or downloaded manually ver.01.02.06-010411.

This will help maintain script validity and help people to resolve their issues.

Troubleshooting

For any issues occurred during FW installation refer to generated mbwe/mbwe-status.log file, which you should backup before Ubuntu shutdown.

1. MBWE still does not boot

Instead of using USB-to-SATA adapter (or any other external hotplug way) try to connect HDD directly to the SATA controller in your PC before starting the procedure.  This can help as reported by user Jack.

As you power MBWE first time, it should go off after a couple of seconds. Then power it on again, holding power button for 3 seconds.
Make also sure that HDD SATA connector sits closely in SATA MBWE socket. I know it’s hard to check, but it’s a lousy construction and can fail. I would even disassemble the case to see better that connection and to be 100% sure before the final give up.

If above steps failed, the last thing you can do is to check your HDD against bad sectors (once again, even if you’ve taken that action at prerequisites step). MBWE firmware is based on some absolute blocks (especially boot sectors) and thus they cannot be bad or mapped as bad (that’s why you have to start with clean/raw HDD instead of formatted).

2. Second disk failed

If you’ve encountered Failed to create volume or missing after second disk was installed (only SPAN is available), here is what you can do:

1. Clean second disk before installation.

or

2. Change manually RAID type in file /proto/SxM_webui/admin/config.xml, editing at md2 (DataVolume) tag <level>s</level> to <level>1</level> (explanation: 0 is for RAID 0, 1 for RAID 1, j for JBOT, s for SPAN). You can access this file during FW installation procedure (there is pause point after NAS OS is installed) or any time later, mounting disk under Ubuntu in a manner described here but finding icon called ‚1’ (OS partition).

MBWE config xml

3. After a few minutes MBWE gets unresponsive

If your MBWE freezes (hangs) after some time of fully operational state it means that the processor has got overheated (probably you’ve used different disks than WD Greens that have caused temperature arise inside MBWE to 60 Celsius degrees or more). The solution is: a) to add MBWE processor radiator, glued with thermal paste and/or b) to stick to WD Green HDDs.

Discussion 603 komentarze

  1. Alfonso S

    Awesome, works great!!!!

  2. harry wwc

    G’day,

    just went through this several times.

    And it (mostly) works 0 thus far.

    I have a MBWE-II – R/N B3D – supposedly a troublesome one when combined with (you guessed it) 2x 3TB EZRX Caviar Greens :/

    I removed my existing drives from the chassis (easy to do on my ‚server’ class system), inserted one of the EZRX drives and booted from CentOS6 live dvd.
    Followed the above instructions and – a few minor complaints that the partitions were not „properly aligned”, but all went well.

    Removed the drive and installed it into my MBWS-II and fired it up. Works.
    Started a windows machine and WD-Link sees the device.

    I’m now trying to deal with the Web Interface – sometimes it’s there, sometimes it’s not.

    But I am about 85% the way there 🙂 I suspect (due to poor ping times) that the box may be working on something – so I will leave it alone overnight 🙂

    kind regards,

    Harry

    • You might have to wait a bit. On first boot it will spend some time to format the data partition.

      • harry wwc

        Hi Adrian, et.al.,

        with out a doubt that was the issue – inital format of the remainder of that inital disk (over 2TiB) – the second drive was added a little later, and the data restored from the „backups” and now we have nearly 5.7TiB total!

        Again, thanks to Krzysztof and everyone else for the instructions and the feedback here.

        And thanks to the WD for a lesson in patience 😀

        Kind regards,

        Harry

  3. Hi there,

    I’m very very pleased and happy to announce smooth success with a WD30EFRX Red 3TB!!!
    (Firmware version 01.02.14 with MioNet 4.3.1.13)

    FYI, no tweaks at all, just followed the procedure step by step exactly as described here.

    Happy moddin’ to you all!!! 🙂 🙂 🙂

    Fred

    • Thx for dropping!

      I think most non-green WD Caviars will work without modding FW until they got WDC string in description (that is the only check). The real question is: How do they perform thermally in passively cooled MBWE enclosure? Anyway, it doesn’t make any sense to use better HDD than green in such slow NAS hardware.

  4. Jorge Quesada

    THANKS FOR THE TUTORIAL!!! I bought two 4TB WD40EZRX disks and worked like a charm on my old MBWEII R/N B3D… did have to login through ssh and edit /proto/SxM_webui/admin/config.xml to build raid. Setup the script from a USB key using Ubuntu 12.10. Did place jumper on both disks to limit data transfer to 3Gb/s.

    Thanks again… my family has more photo storage now!!

    • Good to hear that 4TB works fine!
      Please answer the following questions:
      1) Was config.xml editing necessary to run your MBWE?
      1) Was jumper setting necessary to run your MBWE?
      … or Did you do that just precautionary?

  5. Thanks for this article. Helped me reuse the NAS. But I put in a 500GB HDD

Give your feedback